const regex = /<es2:ITEM>[^-]+-([^-]+)-[^-]+<\/es2:ITEM>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<es2:ITEM>[^-]+-([^-]+)-[^-]+<\\\/es2:ITEM>', 'gm')
const str = `<es2:ITEM>C2231597H88-KK&JK-M13122</es2:ITEM>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}