$re = '/<es2:ITEM>[^-]+-([^-]+)-[^-]+<\/es2:ITEM>/m';
$str = '<es2:ITEM>C2231597H88-KK&JK-M13122</es2:ITEM>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);