// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<es2:ITEM>[^-]+-([^-]+)-[^-]+<\/es2:ITEM>").unwrap();
let string = "<es2:ITEM>C2231597H88-KK&JK-M13122</es2:ITEM>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}