re = /<es2:ITEM>[^-]+-([^-]+)-[^-]+<\/es2:ITEM>/m
str = '<es2:ITEM>C2231597H88-KK&JK-M13122</es2:ITEM>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end