#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![#\/.])(?!.*[#\/.]$).*"
Local $sString = "path/" & @CRLF & _
"/path" & @CRLF & _
"/folder/path/" & @CRLF & _
"/folder/folder/path" & @CRLF & _
"/folder/path#hash" & @CRLF & _
"/folder/path.ext" & @CRLF & _
"path"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")