import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![#\\/.])(?!.*[#\\/.]$).*";
final String string = "path/\n"
+ "/path\n"
+ "/folder/path/\n"
+ "/folder/folder/path\n"
+ "/folder/path#hash\n"
+ "/folder/path.ext\n"
+ "path";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}