using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![#\/.])(?!.*[#\/.]$).*";
string input = @"path/
/path
/folder/path/
/folder/folder/path
/folder/path#hash
/folder/path.ext
path";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}