using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{1,2})(\d{2})";
string substitution = @"$1:$2";
string input = @"1430
1230a
1230am
430a";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}