package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\d{1,2})(\d{2})`)
var str = `1430
1230a
1230am
430a`
var substitution = "$1:$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}