import Foundation
let pattern = #"\b(\d{1,2})(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1430
1230a
1230am
430a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)