re = /\b(\d{1,2})(\d{2})/
str = '1430
1230a
1230am
430a'
subst = '$1:$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result