#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"app\":\s\{((.|\n)*)\"local\""
Local $sString = "{" & @CRLF & _
" "app": {" & @CRLF & _
" "local": "True"," & @CRLF & _
" "dependency_env": "dev"" & @CRLF & _
" }," & @CRLF & _
" "engine": {" & @CRLF & _
" "disable_jwt_check": "true"," & @CRLF & _
" "jwt_private_key": "sph59tZqVrjqz3BiVUnXvKRgd6BxDkN2E+TAjy96wfASO4/5DGJIQlZvnNSt4H7wKLQ0b1J5AdNJ7315B9My6w=="," & @CRLF & _
" "jwt_issuer": "https://hbgpmwapi-dev.kantar.com"" & @CRLF & _
" }," & @CRLF & _
" "azure": {" & @CRLF & _
" "app_id": "efe4d19e-880e-480e-8e0c-f86c9fd5872c"," & @CRLF & _
" "app_key": "b1e5em8uILeqAI.0jt=zg[mJHSaaHKz:"," & @CRLF & _
" "env": "dev"," & @CRLF & _
" "storage_key": "pKhqboH2XDRpYNLco4vyPapHNd7Ao/BO28yFBD0ooSSn/828NLMfKkkzdrqUyeeA2312Y9xAix1T/YdAHkbZCw=="," & @CRLF & _
" "storage_container": "marketingpressure"," & @CRLF & _
" "storage_endpoint": "https://hbgenginestorage.blob.core.windows.net"" & @CRLF & _
" }," & @CRLF & _
" "URL": {" & @CRLF & _
" "main": "http://localhost:3838"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")