# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"app\":\s\{((.|\n)*)\"local\""
test_str = ("{\n"
" \"app\": {\n"
" \"local\": \"True\",\n"
" \"dependency_env\": \"dev\"\n"
" },\n"
" \"engine\": {\n"
" \"disable_jwt_check\": \"true\",\n"
" \"jwt_private_key\": \"sph59tZqVrjqz3BiVUnXvKRgd6BxDkN2E+TAjy96wfASO4/5DGJIQlZvnNSt4H7wKLQ0b1J5AdNJ7315B9My6w==\",\n"
" \"jwt_issuer\": \"https://hbgpmwapi-dev.kantar.com\"\n"
" },\n"
" \"azure\": {\n"
" \"app_id\": \"efe4d19e-880e-480e-8e0c-f86c9fd5872c\",\n"
" \"app_key\": \"b1e5em8uILeqAI.0jt=zg[mJHSaaHKz:\",\n"
" \"env\": \"dev\",\n"
" \"storage_key\": \"pKhqboH2XDRpYNLco4vyPapHNd7Ao/BO28yFBD0ooSSn/828NLMfKkkzdrqUyeeA2312Y9xAix1T/YdAHkbZCw==\",\n"
" \"storage_container\": \"marketingpressure\",\n"
" \"storage_endpoint\": \"https://hbgenginestorage.blob.core.windows.net\"\n"
" },\n"
" \"URL\": {\n"
" \"main\": \"http://localhost:3838\"\n"
" }\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.