import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"app\\\":\\s\\{((.|\\n)*)\\\"local\\\"";
final String string = "{\n"
+ " \"app\": {\n"
+ " \"local\": \"True\",\n"
+ " \"dependency_env\": \"dev\"\n"
+ " },\n"
+ " \"engine\": {\n"
+ " \"disable_jwt_check\": \"true\",\n"
+ " \"jwt_private_key\": \"sph59tZqVrjqz3BiVUnXvKRgd6BxDkN2E+TAjy96wfASO4/5DGJIQlZvnNSt4H7wKLQ0b1J5AdNJ7315B9My6w==\",\n"
+ " \"jwt_issuer\": \"https://hbgpmwapi-dev.kantar.com\"\n"
+ " },\n"
+ " \"azure\": {\n"
+ " \"app_id\": \"efe4d19e-880e-480e-8e0c-f86c9fd5872c\",\n"
+ " \"app_key\": \"b1e5em8uILeqAI.0jt=zg[mJHSaaHKz:\",\n"
+ " \"env\": \"dev\",\n"
+ " \"storage_key\": \"pKhqboH2XDRpYNLco4vyPapHNd7Ao/BO28yFBD0ooSSn/828NLMfKkkzdrqUyeeA2312Y9xAix1T/YdAHkbZCw==\",\n"
+ " \"storage_container\": \"marketingpressure\",\n"
+ " \"storage_endpoint\": \"https://hbgenginestorage.blob.core.windows.net\"\n"
+ " },\n"
+ " \"URL\": {\n"
+ " \"main\": \"http://localhost:3838\"\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}