package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"app\":\s\{((.|\n)*)\"local\"`)
var str = `{
"app": {
"local": "True",
"dependency_env": "dev"
},
"engine": {
"disable_jwt_check": "true",
"jwt_private_key": "sph59tZqVrjqz3BiVUnXvKRgd6BxDkN2E+TAjy96wfASO4/5DGJIQlZvnNSt4H7wKLQ0b1J5AdNJ7315B9My6w==",
"jwt_issuer": "https://hbgpmwapi-dev.kantar.com"
},
"azure": {
"app_id": "efe4d19e-880e-480e-8e0c-f86c9fd5872c",
"app_key": "b1e5em8uILeqAI.0jt=zg[mJHSaaHKz:",
"env": "dev",
"storage_key": "pKhqboH2XDRpYNLco4vyPapHNd7Ao/BO28yFBD0ooSSn/828NLMfKkkzdrqUyeeA2312Y9xAix1T/YdAHkbZCw==",
"storage_container": "marketingpressure",
"storage_endpoint": "https://hbgenginestorage.blob.core.windows.net"
},
"URL": {
"main": "http://localhost:3838"
}
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}