using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Detection Date:.*?\*\*(.+?)\*\*.*?Confidence:";
string input = @"Detection Date:
**01/20/2015**
Confidence:";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}