package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)Detection Date:.*?\*\*(.+?)\*\*.*?Confidence:`)
var str = `Detection Date:
**01/20/2015**
Confidence:`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}