$re = '/Detection Date:.*?\*\*(.+?)\*\*.*?Confidence:/ms';
$str = 'Detection Date:
**01/20/2015**
Confidence:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);