import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:(?:(?:-?(?:usd|\\$)|(?:usd|\\$)-)(?:(?:0|[1-9]\\d*)?(?:\\.\\d+)?(?<=\\d)))|(?:-?(?:(?:0|[1-9]\\d*)?(?:\\.\\d+)?(?<=\\d))(?:usd|\\$)))\\s*$";
final String string = " $456 \n"
+ " $45.6\n"
+ " $.5\n"
+ " $-45\n"
+ " -$45\n"
+ " usd-456\n"
+ " usd46\n"
+ " usd4.6\n"
+ " usd.46\n"
+ " 1$\n"
+ " 1.5$\n"
+ " .5$\n"
+ " -.5$\n"
+ " 5usd\n"
+ " 456usd\n"
+ "------------\n"
+ " $000\n"
+ " $.\n"
+ " 00.0$\n"
+ " 455$abc\n"
+ " abc$123\n"
+ " abcuds1\n"
+ " jhb$5665usdjnjnb\n"
+ " $usd1555\n"
+ " usd$768\n"
+ " $566usd\n"
+ " $5788usdbjhj ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}