const regex = /^\s*(?:(?:(?:-?(?:usd|\$)|(?:usd|\$)-)(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d)))|(?:-?(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d))(?:usd|\$)))\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:(?:(?:-?(?:usd|\\$)|(?:usd|\\$)-)(?:(?:0|[1-9]\\d*)?(?:\\.\\d+)?(?<=\\d)))|(?:-?(?:(?:0|[1-9]\\d*)?(?:\\.\\d+)?(?<=\\d))(?:usd|\\$)))\\s*$', 'gm')
const str = ` \$456
\$45.6
\$.5
\$-45
-\$45
usd-456
usd46
usd4.6
usd.46
1\$
1.5\$
.5\$
-.5\$
5usd
456usd
------------
\$000
\$.
00.0\$
455\$abc
abc\$123
abcuds1
jhb\$5665usdjnjnb
\$usd1555
usd\$768
\$566usd
\$5788usdbjhj `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}