$re = '/^\s*(?:(?:(?:-?(?:usd|\$)|(?:usd|\$)-)(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d)))|(?:-?(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d))(?:usd|\$)))\s*$/m';
$str = ' $456
$45.6
$.5
$-45
-$45
usd-456
usd46
usd4.6
usd.46
1$
1.5$
.5$
-.5$
5usd
456usd
------------
$000
$.
00.0$
455$abc
abc$123
abcuds1
jhb$5665usdjnjnb
$usd1555
usd$768
$566usd
$5788usdbjhj ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);