# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(?:(?:(?:-?(?:usd|\$)|(?:usd|\$)-)(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d)))|(?:-?(?:(?:0|[1-9]\d*)?(?:\.\d+)?(?<=\d))(?:usd|\$)))\s*$"
test_str = (" $456 \n"
" $45.6\n"
" $.5\n"
" $-45\n"
" -$45\n"
" usd-456\n"
" usd46\n"
" usd4.6\n"
" usd.46\n"
" 1$\n"
" 1.5$\n"
" .5$\n"
" -.5$\n"
" 5usd\n"
" 456usd\n"
"------------\n"
" $000\n"
" $.\n"
" 00.0$\n"
" 455$abc\n"
" abc$123\n"
" abcuds1\n"
" jhb$5665usdjnjnb\n"
" $usd1555\n"
" usd$768\n"
" $566usd\n"
" $5788usdbjhj ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.