package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/([^\/]+)\/?$`)
var str = `https://siteadress/users/username/`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}