import re
regex = re.compile(r".*\/([^\/]+)\/?$")
test_str = "https://siteadress/users/username/"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)