re = /.*\/([^\/]+)\/?$/
str = 'https://siteadress/users/username/'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result