using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\x1B]*)(?:\x1B[[]([^m]*)m)([^\x1B]*)";
string input = @"
blah blah [4mRunning ""loadData"" task[24m [4mRunning ""loadData"" task[24m";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}