package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\x1B]*)(?:\x1B[[]([^m]*)m)([^\x1B]*)`)
var str = `
blah blah [4mRunning "loadData" task[24m [4mRunning "loadData" task[24m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}