// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\x1B]*)(?:\x1B[[]([^m]*)m)([^\x1B]*)").unwrap();
let string = "
blah blah [4mRunning \"loadData\" task[24m [4mRunning \"loadData\" task[24m";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}