re = /([^\x1B]*)(?:\x1B[[]([^m]*)m)([^\x1B]*)/m
str = '
blah blah [4mRunning "loadData" task[24m [4mRunning "loadData" task[24m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end