package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0+\b`)
var str = `+0 000 000-00-00`
var substitution = "[$0]"
fmt.Println(re.ReplaceAllString(str, substitution))
}