use strict;
my $str = '+0 000 000-00-00';
my $regex = qr/\b0+\b/mp;
my $subst = '[$0]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";