import Foundation
let pattern = #"\b0+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"+0 000 000-00-00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$0]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)