$re = '/\b0+\b/m';
$str = '+0 000 000-00-00';
$subst = "[$0]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;