using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(image)\]([^\[]+)\[(caption)\]([^\[]+)\[/\3\]\[/\1\]";
string substitution = @"<figure><img src='$2'/><figcaption>$4</figcaption></figure>";
string input = @"[image]bdaypic.jpg[caption]My pic[/caption][/image]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}