$re = '~\[(image)\]([^\[]+)\[(caption)\]([^\[]+)\[/\3\]\[/\1\]~';
$str = '[image]bdaypic.jpg[caption]My pic[/caption][/image]';
$subst = "<figure><img src='$2'/><figcaption>$4</figcaption></figure>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;