import re
regex = re.compile(r"\[(image)\]([^\[]+)\[(caption)\]([^\[]+)\[/\3\]\[/\1\]")
test_str = "[image]bdaypic.jpg[caption]My pic[/caption][/image]"
subst = "<figure><img src='$2'/><figcaption>$4</figcaption></figure>"
result = regex.sub(subst, test_str)
if result:
print(result)