using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!^[ _-]|.*[ _-]$|.* _|.*_ )[\w -]*$";
string input = @"Hello_World
Hello _World
Hello_ World
Hello _ World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
_HelloWorld
HelloWorld_
f*f
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}