re = /^(?!^[ _-]|.*[ _-]$|.* _|.*_ )[\w -]*$/m
str = 'Hello_World
Hello _World
Hello_ World
Hello _ World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
_HelloWorld
HelloWorld_
f*f
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end