use strict;
my $str = 'Hello_World
Hello _World
Hello_ World
Hello _ World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
_HelloWorld
HelloWorld_
f*f
';
my $regex = qr/^(?!^[ _-]|.*[ _-]$|.* _|.*_ )[\w -]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}