$re = '/^(?!^[ _-]|.*[ _-]$|.* _|.*_ )[\w -]*$/m';
$str = 'Hello_World
Hello _World
Hello_ World
Hello _ World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
_HelloWorld
HelloWorld_
f*f
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);