#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)^[\w]+_[\w]+_[\w]{2,5}$"
Local $sString = "blah_blah_suffix" & @CRLF & _
"" & @CRLF & _
"where suffix is any string that has length from 2 to 5 characters. So I want accept strings" & @CRLF & _
"" & @CRLF & _
"blah_blah_aa" & @CRLF & _
"blah_blah_abcd" & @CRLF & _
"" & @CRLF & _
"but discard" & @CRLF & _
"" & @CRLF & _
"blah_blah_a" & @CRLF & _
"blah_aaa" & @CRLF & _
"blah_blah_aaaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")