re = /^[\w]+_[\w]+_[\w]{2,5}$/im
str = 'blah_blah_suffix
where suffix is any string that has length from 2 to 5 characters. So I want accept strings
blah_blah_aa
blah_blah_abcd
but discard
blah_blah_a
blah_aaa
blah_blah_aaaaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end