import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w]+_[\\w]+_[\\w]{2,5}$";
final String string = "blah_blah_suffix\n\n"
+ "where suffix is any string that has length from 2 to 5 characters. So I want accept strings\n\n"
+ "blah_blah_aa\n"
+ "blah_blah_abcd\n\n"
+ "but discard\n\n"
+ "blah_blah_a\n"
+ "blah_aaa\n"
+ "blah_blah_aaaaaaa";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}