package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)^[\w]+_[\w]+_[\w]{2,5}$`)
var str = `blah_blah_suffix
where suffix is any string that has length from 2 to 5 characters. So I want accept strings
blah_blah_aa
blah_blah_abcd
but discard
blah_blah_a
blah_aaa
blah_blah_aaaaaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}