using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http):\/\/(?:[^\/\r]+)(?:\/)([^\r]*)?";
string input = @"http://www.twitter.com/mehwish_sattar
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}