$re = '/(?:http):\/\/(?:[^\/\r]+)(?:\/)([^\r]*)?/';
$str = 'http://www.twitter.com/mehwish_sattar
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);