re = /(?:http):\/\/(?:[^\/\r]+)(?:\/)([^\r]*)?/
str = 'http://www.twitter.com/mehwish_sattar
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end