#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)^\s*(\d+)\s*(.*\S) .*(?:\R\h*+(?!F\d{6}\b).*)*\R\h*(F\d{6})"
Local $sString = " 1 DOPPEL TYP I MEERBLICK HALBPENSION" & @CRLF & _
" FRĂHBUCHER 20%" & @CRLF & _
" INKL. REISELEITUNG UND TRANSFER AB/BIS" & @CRLF & _
" FLUGHAFEN" & @CRLF & _
" KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE" & @CRLF & _
" F367655 HERR WILKAT, CHRISTINE O 05.01.15" & @CRLF & _
" F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")