const regex = /^\s*(\d+)\s*(.*\S) .*(?:\R\h*+(?!F\d{6}\b).*)*\R\h*(F\d{6})/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(\\d+)\\s*(.*\\S) .*(?:\\R\\h*+(?!F\\d{6}\\b).*)*\\R\\h*(F\\d{6})', 'u')
const str = ` 1 DOPPEL TYP I MEERBLICK HALBPENSION
FRĂHBUCHER 20%
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE
F367655 HERR WILKAT, CHRISTINE O 05.01.15
F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}