re = /^\s*(\d+)\s*(.*\S) .*(?:\R\h*+(?!F\d{6}\b).*)*\R\h*(F\d{6})/
str = ' 1 DOPPEL TYP I MEERBLICK HALBPENSION
FRĂHBUCHER 20%
INKL. REISELEITUNG UND TRANSFER AB/BIS
FLUGHAFEN
KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE
F367655 HERR WILKAT, CHRISTINE O 05.01.15
F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15'
# Print the match result
str.match(re) do |match|
puts match.to_s
end